OSGeo
OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
At a glance
Actively exploited in the wild — prioritise confirming exposure.
Medium rather than High: exposure is scored at a default because we cannot see your systems or suppliers. If you run or depend on OSGeo GeoServer, treat it as High.
Briefing
- Do not treat uncorroborated claims as confirmed breaches.
Questions to ask IT
- Do we run OSGeo GeoServer, and is every instance on a fixed release (2.26.2 or 2.25.6, or later)?
- Is any of it reachable from the internet?
- Have we checked whether it has already been used against us?
- If it is not yet patched, what mitigation is in place, and will the fix be done by 11 Nov?
Next steps
- Confirm exposure, mitigation status and any service interruption risk.
Vulnerability facts
Full CVE detail CVE-2025-58360- 8.2 · HighExploitable over the network without any account, and no one has to click or open anything. High impact on confidentiality; low on availability.CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
- Listed: attacks using it have been seen (on the catalogue since )
- Elevated attack likelihood (~61.2% in 30 days)
- Before 2.26.2, before 2.25.6
- 2.26.2, 2.25.6
Versions are as the CVE record states them; check the vendor advisory before planning a fix.
No technical write-up beyond these facts and the summary below yet.
Next steps
- Confirm whether affected products/versions are present and prioritise patching or mitigations
Summary
- OSGeo GeoServer contains an improper restriction of XML external entity reference vulnerability that occurs when the application accepts XML input through a specific endpoint /geoserver/wms operation GetMap and could allow an attacker to define external entities within the XML request.
- CVE-2025-58360 is listed in known-exploited catalogue (exploitation in the wild)
- Authoritative catalogues report active exploitation of this vulnerability.
Why this matters in the UK
- Known-exploited catalogue reports exploitation in the wild
Products and services involved
- OSGeo GeoServer82% match confidence · CVE-2025-58360
Part of Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine Vulnerability
Pulse
Last checked 4d ago · Recheck overdue since 5 Nov 2026, 22:34 UK time · 3 quiet checks collapsed
in the next 30 days first recorded at 61.2% (elevated likelihood signal, not confirmed exploitation). Suggested changed to 7d.
Elevated — confirm exposure; this is a probability signal, not confirmed exploitation.
2 quiet checks hidden.
Sources
OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
How we know
Statements extracted from sources. Higher confidence means stronger corroboration.
- ConfirmedHeadline90% confidence
OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
- ConfirmedSummary fact75% confidence
OSGeo GeoServer contains an improper restriction of XML external entity reference vulnerability that occurs when the application accepts XML input through a specific endpoint /geoserver/wms operation GetMap and could allow an attacker to define external entities within the XML request. Affects OSGeo GeoServer. Known ransomware campaign use: Unknown.
- ConfirmedCVE identifier95% confidence
Event involves CVE-2025-58360
- ConfirmedKnown-exploited catalogue98% confidence
CVE-2025-58360 is listed in known-exploited catalogue (exploitation in the wild)

